Partial payment processing outage
Incident Report for Builder Prime
Resolved
All services are restored!
Posted Sep 26, 2024 - 13:48 EDT
Identified
The vendor has identified the issue and is working to resolve and restore normal service operations as quickly as possible. We appreciate your patience and will provide further updates as more information becomes available.
Posted Sep 26, 2024 - 13:18 EDT
Investigating
There is a global payments outage that is having impact on Builder Prime and our payments partners. Some payments are going through, but others are failing. We've been informed that this is being worked on and hope to have this fully restored ASAP.
Posted Sep 26, 2024 - 12:43 EDT
This incident affected: Web and Mobile Apps.